Barchart Trader runs on almost all modern desktop operating systems, and no separate Java installations or software updates are required - Trader has its own runtime engine and updates itself automatically.

System Requirements:

Operating System:


Windows: XP, Vista, 7, 8
Mac OS X: 10.5 or higher
Ubuntu: 10.04 or higher

Hardware:

Internet: High-speed internet access (cable/DSL/fiber)
Memory: 2GB (4GB recommended)
Processor: Intel i3 or equivalent (i5 recommended)
Disk space: 500MB